PostCSS 插件postcss-lazyimagecss:自动填写width / height 属性

1,481
PostCSS 插件postcss-lazyimagecss:自动填写width / height 属性
  • 5.00 / 5 5
5.00分(1票)
PostCSS 插件postcss-lazyimagecss:自动填写width / height 属性

postcss-lazyimagecss 是Jeff 基于gulp-lazyimagecss 开发的一个PostCSS 插件,实现的功能是在CSS 中自动添加width / height 属性。项目地址:https://github.com/Jeff2Ma/postcss-lazyimagecss (欢迎给个star!)

安装使用

1
npm install postcss-lazyimagecss --save-dev

在Gulp 中使用:

1
2
3
4
5
6
7
8
9
10
11
12
var gulp = require('gulp');
var postcss = require('gulp-postcss');
var lazyimagecss = require('postcss-lazyimagecss');
 
gulp.task('css', function () {
    return gulp.src('./src/css/*.css')
        .pipe(another-plugin())
        .pipe(postcss([lazyimagecss({
            imagePath: ['../img','../slice']
        })]))
        .pipe(gulp.dest('./dist/css'));
});

更多使用方式请查看项目Readme.

特色简介

  • 支持jpg/jpeg/png/gif/bmp/svg 等格式的图片文件;
  • 支持二倍图并在widthheight 属性的基础上自动增加background-size 属性;
  • background-image: url()background: url()下的地址均能被检测到;
  • 如果相关widthheightbackground-size 属性已提前写好,则不会增加添加。

更多

更多请查看项目主页 https://github.com/Jeff2Ma/postcss-lazyimagecss

最后感谢hzlzh and littledu 提供的灵感及思路。

暂时木有评论啊,等您坐沙发呢!

打破沉默,我来发表评论鸟~